Forever Spinning Icon on Login

Hello Everyone,

First -time user here trying to get things (RServer IDE, that is) working. I have installed the RPM successfully and the web server comes up. But when I login, which is successful, I just get the spinning icon.

This is running on CentOS Linux release 7.4.1708 (Core). There are no logs in /var/log/rstudio-server/. Where do I begin troubleshooting this?

Thanks in advance.

A couple of other data points:

  • Running R from the shell works fine.
  • There are no errors in /var/log/messages or /var/log/secure.
  • When I ran rserver from the shell without daemonizing it, nothing appeared on the console.

This is really perplexing, so I would appreciate any debug tips anyone might have.

I am assuming this is for RStudio Server?

Have you worked through these: ?

Thanks for the reply. Yes, this is for RStudio Server.

I have worked through those steps. As a mentioned, there is nothing in the logs. But here is the output from sessionInfo():

R version 3.4.3 (2017-11-30)
Platform: x86_64-redhat-linux-gnu (64-bit)
Running under: CentOS Linux 7 (Core)

Matrix products: default
BLAS/LAPACK: /usr/lib64/R/lib/


attached base packages:
[1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached):

If the troubleshooting guide is not helpful, there is this advice;

To summarize:

Unfortunately, I don't have a clue on this one. It is almost impossible for us to investigate this one either without being on your machine. Wish there was more we could do to help.

I purged RStudio in its entirety and reinstalled and now it works again.
My suspicion is that it has something to do with the version of the JVM.

I did reinstall and that didn't help. Perhaps there is an unmet dependency that the RPM has not accounted for. This is installed on a minimal version of CentOS, so nothing can be presumed to be present.

The OP mentioned that they thought it might be a Java issue. I do have java-1.8.0-openjdk- already installed. Is there documentation which lists the dependencies and requirements? I haven't been able to find it, if it exists **.

** Other than what is documented here: and here:

Good news. And I have no idea why this is the case--it seems like a bug--but the problem was that it only works with the fully-qualified name (i.e., but not with just the hostname. This is true even though it resolves the name properly.

1 Like