Flexdashboard shiny app crashes on shiny server using highcharter package

Hi all!
I have a shiny app in a flexdashboard and locally it works well.
Now I want to put it online using Shiny Server, but it doesn't works :confused:
The stranger thing is that it is related with the use of highcharter package. Because, a demo.rmd file work well, but not mi file (that use the highcharter package).

Even with this example file


I received the following error message (while deploying on shiny server)

I don't know what happened, or what is the problem. Locally, everything is ok :confused:

We need more information to help you, what do your application logs say? you can find application logs on this path on the server /var/log/shiny-server

Thanks @andresrcs. Here is the log:

Apparently, the highcharter package is not installed. But locally in R, is installed

The way I installed the package was:

wget http://cran.r-project.org/src/contrib/highcharter_0.9.4.tar.gz


r cmd install highcharter_0.9.4.tar.gz

Do I have to install the package in another way, o something like that?
Thanks for your help!

Since the app runs on the server once is deployed, the package needs to be installed on the server as well. Also, shiny apps run as the shiny user so the package has to be available for that user as well, the usual way of dealing with this is by installing packages as root from a terminal with a command like this

sudo su - -c "R -e \"install.packages('highcharter', repos='https://cran.rstudio.com/')\""

Thanks for your answer @andresrcs, nevertheless, it still doesn't work :confused:

The error message says the server is not able to connect to that particular CRAN repository, is your server under connectivity restrictions of some kind? If so, you need to change the repository to whichever is allowed by your organization or talk to your IT security department.

Ok, I'll check it. Thanks for all until now. I'll be back!

Apparently, there were no problems regarding connectivity restrictions. The command that worked was:

sudo su - -c "R -e \"install.packages('highcharter', repos='https://cran.rstudio.com')\""

Thanks for all!

It is the exact same command as before so if you are able to connect to the package repository now I think something has to have changed in your network configuration.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.