File Fails to Import on Knit

On a MacBook, I'm working on an R Markdown that imports a file using the code:

BaseData <- read_excel("~/Desktop/Marlin Thomas/Russia/BaseData.xlsx")

When I execute the above as part of a chunk, the file imports. If I highlight and run the code, the file imports. When I execute knit on the markdown, there is an error message No such file or directory. The consoles reports that X11 library is missing. Attempts to import other files from the same directory during knit work fine. I've tried renaming the file and saving it as css and using read_csv(). I've run the above commands in another markdown with the same results. What am I not understanding about knit or about this file name?

I tried importing it via another markdown. Renaming the file. Saving it as a csv file. The file does not import in a knit but imports when a chunk is executed.

What is the issue exactly ?

WHich package does read_excel came from ?

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.