Failure to deploy bookdown via RConnect

I have had a site on bookdown for about 4 months, and have been able to update it regularly without an issue. Recently I updated my R version and some packages and I am running into issues.

  1. The menu options changed for the deployment. I now get this:

followed by a prompt if I would like to replace the existing deployment. I picked 'yes' because I didn't see another way to upload it. I also picked the option with source code, I wasn't sure which to go for.

After it goes through the process of attempting to upload, I get to this point where I get this error:

Would anyone have any suggestions about what to do to fix this?

I should note that I have tried reinstalling foreign a couple of times to see if this easy fix would work, but it doesn't.

My current R Version is 4.0.3

EDIT: I did get this to work in a roundabout way. I opened RStudio using my older version of R (3.5.0) and then it deployed. The bad news is that it deployed at a new URL, likely meaning that I now have two deployments. This book is a textbook, so obviously only having one URL is ideal.

I'm still keen to solve this using R 4.0.3, it's going to be awkward having to revert back each time I want to make changes.

1 Like

Hello! So sorry for the long delay here - are you still encountering this issue? It would be great to get it solved for you!