Failure to build rgdal during deployment

Update: I tried to upload an empty shiny app, only containing 'library(rgdal)' and got the same problem. Is shiny just incompatible with rgdal? Has it always been like this or will there be a fix?

I'm trying to upload a fairly basic map online, this app is running in-program fine, but every time I try to upload my program I get an error:
Error: Unhandled Exception: Child Task 617166892 failed: Error building image: Error building rgdal (1.4-2). Build exited with non-zero status: 1
Execution halted

I have no clue how to get around this please help :frowning:

''' library(tmap)

ui <- fluidPage(
server <- function(input, output) {
output$map <- renderLeaflet({
tm <- tm_shape(Meshblocktest) + tm_fill("X2017", style = "quantile", palette= "Reds")



shinyApp(ui, server)

Have you tried this walk around solution?

Unfortunately this did not work upon publishing I had the exact same error once it tried to install rgdal.

This issue looks to have been fixed overnight. No problems anymore! :slight_smile:

If your question's been answered (even by you!), would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it: