Failing to install dplyr from GitHub when running R 4.0.0.


I am getting the following error when trying to install the dev version of dplyr from GitHub (using remotes::install_github) under R 4.0.0:

   clang-7: error: no such file or directory: '/Library/Frameworks/R.framework/Resources/lib/libc++abi.1.dylib'
   make: *** [] Error 1
   ERROR: compilation failed for package ‘dplyr’

I switched back to R 3.6.2 and it worked just fine.

I'm on a Mac, running macOS 10.15.4. I believe my command line tools are up to date. I have googled for suggestions but haven't found anything that has helped. I would appreciate any help in resolving this. It is one of a few issues I've encountered with package compilation since upgrading - hopefully if this can be resolved, the other issues will go too! Thanks for your help.

1 Like

I had a similar error, but resolved when I allowed updating of rlang - worth trying to update dependencies.

Thanks MBN. I had already tried updating all dependencies, both using the latest CRAN versions and the latest development versions from GitHub. I still get the same error.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.