Failed to install 'Package' from GitHub, Rcmd.exe failed

Hi All,

I recently tried to start Rstudio, however, the program just hung at the R logo. I tried removing R and installing everything from scratch. My Rstudio could finally open (yay), unfortunately, when I tried to install packages from Github using the package devtools (as I have in the past) I get the following error:

Code I ran: devtools::install_github("joey711/phyloseq")

The error message:

I tried to google my error and stumbled upon multiple posts (1,2). I specifically looked into this error message: Error: Failed to install 'phyloseq' from GitHub:
! System command 'Rcmd.exe' failed
In addition: Warning message:
In i.p(...) :
installation of package ‘GenomeInfoDbData’ had non-zero exit status
However, none of the mentioned fixes worked for me. Please let me know if you have any ideas on how I could fix this error.

My R version:

platform x86_64-w64-mingw32
arch x86_64
os mingw32
crt ucrt
system x86_64, mingw32
major 4
minor 3.0
year 2023
month 04
day 21
svn rev 84292
language R
version.string R version 4.3.0 (2023-04-21 ucrt)
nickname Already Tomorrow

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.