Failed to install package e1071 in the latest Rstudio Version 1.1.456

Hi all,
I have a problem with install package e1071 in rstudio. Basically, everytime i try to install e1071, it returned 2 errors related to cygwin screenshots below . I am using window 10.


Basically, the image is saying it could not find the entry point "getloadavg" in the particular path "c:\cygwin64\bin\make.exe"

I tried to install the "make" package in cygwin. I still get the same error after the installation. To be honest, I do not want my R and RStudio to be running cygwin as an underlying. But I have no idea how to change that.

How can I run R and Rstudio without having to deal with cygwin at all ? Because at the moment, I have no idea why is cygwin relevant at all. So how do I just run R and Rstudio completely separate from cygwin ?

Please kindly help, as this is really bugging me. Sorry being repetitive.

Thanks for reading.

Are you trying to install packages from source? If so, you need Rtools:

It comes with its own set of utilities (e.g. make) that are known to work well with the R package build process.