Failed to deploy app 'Discovered a previously deployed app named xxxx' STUCK 6 HOURS TROUBLESHOOTING

I've been trying to deploy a shiny app created through R studio, it says 'Successfully deployed to' and then an error message pops up on the website, i check the logs and i have to same error message everytime saying 'discovered a previous deployed app named 'DVA3' which i have already terminated, plus I've been using ' rsconnect::deployApp(forceUpdate = TRUE, appName = "newappnameeverytime") ' a new app name every time but still it comes up with the same error message saying DVA3 is there even though I've named it something else. I have the relevant R version which I had to change to 4.2.2, my reconnect was on the latest then i downgraded to one version below and it still doesn't work.

I have to submit this by tonight for my assignment but I've been stuck troubleshooting for the past 6 hours even though everything already done. I can run my app locally but just not on the Please for the love of god someone help.

I've also deleted all created files in the reconnect folder of the folder my app.r file is in.

This is a long-shot, but since RStudio is involved you might try resetting RStudio's state as well as cleaning out the rsconnect folder.