fail to load ggpubr

I have installed ggpubr successfully.

when i tried to load the package, i got the following message:

Error: package or namespace load failed for ‘ggpubr’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
there is no package called ‘zip’

I'm using R Studio version Version 1.2.5033


Have you tried installing the missing dependency?


No, I didn't install any zip package.

After installing, I can see a zip file called saved in the temporary folder. i think the error message refers to the zip file.

The error message says, "there is no package called 'zip'"
This means you are missing that package dependency and you have to install it.

I tried to install zip package, got an error message again

WARNING: Rtools is required to build R packages but is not currently installed. Please download and install the appropriate version of Rtools before proceeding:
trying URL ''
Warning in install.packages :
cannot open URL '': HTTP status was '403 Forbidden'
Error in download.file(url, destfile, method, mode = "wb", ...) :
cannot open URL ''
Warning in install.packages :
download of package ‘zip’ failed

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.