Error with Ggplot2 and Knitting

Whenever I try to use the ggplot() function i get the following error. Even if i just type ggplot(). I get the same error when I try to knit to pdf in R studio. Please help me! I have tried require(), i have tried updating all packages, uninstalling and reinstalling the packages, uninstalling R and R studio and reinstalling, running as admin etc.

Error in namespaceExport(ns, exports) :
undefined exports: AES, digest, digest2int, getVDigest, sha1, sha1_attr_digest, sha1_digest, hmac, makeRaw
In addition: Warning message:
S3 methods ‘print.AES’, ‘sha1.anova’, ‘sha1.array’, ‘’, ‘sha1.character’, ‘sha1.complex’, ‘’, ‘sha1.Date’, ‘sha1.default’

Just wanted to answer my own question for anybody else who has this issue as there does not seem to be a lot of mention of this issue. The issue was with my default libpaths file being a onedrive folder. I fixed this by:


And reinstalled all the packages. Now everything is working.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.