error while loading shared libraries: cannot open shared object file


in an old thread Rstudio .99 won't launch on Ubuntu 15.10 back in 2015, it was observed that the rstudio rpm for Suse is useless since it requires This version of libgstreamer is too old and incompatible. The latest Suse 15.0 ships with

Would it be possible to have a separate rpm for Suse?



Is there a reason you are trying to install RStudio 0.99? It is no longer supported, as 1.0 and now 1.1 have both been released. The latest is 1.1.456. Further, we do now provide SUSE binaries for RStudio Server:

RStudio Server Open Source:
RStudio Server Pro:

Also, RStudio 1.2 is in Preview if you are interested in the bleeding edge:


Also, it is worth mentioning that a lot has changed since 2015 :slight_smile: Are you still encountering this issue?

This is a misunderstanding: I tried yesterday to install the latest rstudio from rpm (RStudio Desktop 1.1.456). I was just mentioning that the problem has been around since 2015. Indeed, with the latest rpm I get on my suse 15.0

rstudio: error while loading shared libraries: cannot open shared object file: No such file or directory

and this error was already reported in the link I provided in my previous email.

The rpm of the bleeding edge version for Suse works;

Ahh yes. I did not realize you were talking about RStudio Desktop. It looks like SUSE builds for Desktop start with 1.2. Glad it worked for you!