Error when publish

I uploaded the "minimal bookdown document" files from github, and builds on rstudio cloud,
and the bookdown document appears. however when i try to publish using rstudio connect, to bookdown, i get errors:

  1. error seems to be about bs4 but i am publishng gitbook. i assed suggested packages but still get the same error.

[Connect] 2022/03/27 16:50:22.327185685 Error: Must install the following packages to use bs4_book():
[Connect] 2022/03/27 16:50:22.327200158 * downlit
[Connect] 2022/03/27 16:50:22.327246226 * xml2
[Connect] 2022/03/27 16:50:22.328019363 Execution halted
[Connect] 2022/03/27 16:50:22.337694086 Error: bookdown::render_book() failed to render the output format 'bookdown::bs4_book'.
[Connect] 2022/03/27 16:50:22.337906567 Execution halted
[Connect] Unable to render the deployed content: Rendering exited abnormally: exit status 1

sometimes it publishes, but the chapters give 404 error when linked.

I am simply trying to use xie's minimal book. it builds fine, but when i try to publish gives error.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.