Error when loading the tidyverse library in R Desktop

Hi Guys!

Got an error when loading the tidyverse library. Below is the error message.

Error: package or namespace load failed for 'tidyverse' in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
namespace 'vctrs' 0.4.2 is already loaded, but >= 0.5.0 is required

This is asking you to update the vctrs package, try with this command


Do you get any error message while doing so?

installed the vctrs packages and tried to load the tidyverse library again but got the same error..

it's also giving a warning message "package "vctrs" is in use and will not be installed.

Restart your R session before trying to update vctrs.

Attached is a screenshot of the R workspace.

You have a lock file from a previous failed install, try manually deleting that folder and then reinstall the vctrs package (no need to reinstall tidyverse)

Also, please do not post screenshots, they are considered a bad practice here, post your console output as formatted code instead. Here is how to do it

Thanks for the info and the advice. I will try to locate that folder and let's see..

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.