Error when installing package with `failed to map segment from shared object`


I am trying to make installation of packages possible on an RStudio Server for individual users, but I am stuck. Everything compiles, but than I get the following message:

> install.packages("storr")
Installing package into ‘/home_rstudio/rainer/R/x86_64-pc-linux-gnu-library/4.1’
(as ‘lib’ is unspecified)
trying URL ''
Content type 'application/x-gzip' length 92403 bytes (90 KB)
downloaded 90 KB

* installing *source* package ‘storr’ ...
** package ‘storr’ successfully unpacked and MD5 sums checked
** using staged installation
** libs
gcc -std=gnu99 -std=gnu11 -I"/usr/share/R/include" -DNDEBUG      -fpic  -g -O2 -fdebug-prefix-map=/build/r-base-i2PIHO/r-base-4.1.2=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g  -c storr.c -o storr.o
gcc -std=gnu99 -std=gnu11 -shared -L/usr/lib/R/lib -Wl,-Bsymbolic-functions -Wl,-z,relro -o storr.o -L/usr/lib/R/lib -lR
installing to /home_rstudio/rainer/R/x86_64-pc-linux-gnu-library/4.1/00LOCK-storr/00new/storr/libs
** R
** inst
** byte-compile and prepare package for lazy loading
** help
*** installing help indices
** building package indices
** installing vignettes
** testing if installed package can be loaded from temporary location
Error: package or namespace load failed for ‘storr’ in dyn.load(file, DLLpath = DLLpath, ...):
 unable to load shared object '/home_rstudio/rainer/R/x86_64-pc-linux-gnu-library/4.1/00LOCK-storr/00new/storr/libs/':
  /home_rstudio/rainer/R/x86_64-pc-linux-gnu-library/4.1/00LOCK-storr/00new/storr/libs/ failed to map segment from shared object
Error: loading failed
Execution halted
ERROR: loading failed
* removing ‘/home_rstudio/rainer/R/x86_64-pc-linux-gnu-library/4.1/storr’
Warning in install.packages :
  installation of package ‘storr’ had non-zero exit status

The downloaded source packages are in

I do not have a clue how I can fix this, and the same error also comes for other packages. Am I missing a system package?



OK - solved with ``: failed to map segment from shared object · Issue #147 · rstudio/renv · GitHub - external drive was mounted with noexec.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.