Error: version `CURL_OPENSSL_3' not found


I just tried to run the CRANsearcher addin and RStudio returned the console error message:

Error in dyn.load(file, DLLpath = DLLpath, ...) :
unable to load shared object '/home/ross/R/x86_64-pc-linux-gnu-library/3.4/curl/libs/':
/usr/lib/x86_64-linux-gnu/ version `CURL_OPENSSL_3' not found (required by /home/ross/R/x86_64-pc-linux-gnu-library/3.4/curl/libs/

This had previously worked just fine. I also got the same error message when attempting to install the CRAN package greybox.

I have not updated from R3.4.4 to R3.5.0, but I did just upgrade from Ubuntu 17.10 to 18.04, so I suspect that's what broke things. Looking at my package manager I can see that libcurl4-openssl-dev is installed,
but libcurl3 (the OpenSSL flavour) is not installed. If I mark libcurl3 for installation it tells me it will remove 29 packages including libcurl4 and all of R. This sounded like a bad idea - so I didn't proceed with installing libcurl3.

An internet search turned up a few hits, none in precisely the same context, and some going back to 2006. The hits are against a range of different software, so i infer that it's a general issue, rather than something specific to R. The general gist of these seems to be that different pieces of software are wanting different versions of libcurl, but the suggested solutions are a bit too esoteric and specific to the software that provoked the issue for me to see how i would apply them.
Some example hits are:

Can someone point me at a fairly straight forward solution to this?




I uninstalled and re-installed the curl package. I presume that curl maintains some info about libcurl that was made out of date when I updated Ubuntu from 17.10 to 18.04

1 Like