Error: Unable to establish connection with R session

When I try to use Rstudio, it appears "Error: Unable to establish connection with R session".
I have already tried to uninstall and reinstall R and Rstudio, also the previous versions, but it still appears this error.
What can I do?

I am also facing this problem since last few days. Please help

same as u, please help. i have tried to download different version of rgui and also r studio, but seems it doesn't help

You can try resetting RStudio's state: Resetting RStudio Desktop's State – RStudio Support

If that doesn't help, could you please send us a diagnostics report? Running a Diagnostic Report – RStudio Support

I downloaded anaconda navigator and there I installed Rstudio and until now I haven't had this problem. Maybe that can help you.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.