Error trying to load dplyr and tidyverse after updating RStudio

I updated RStudio on my MacBook Pro this morning and now I can load tidyverse. I get the following error:

"Error: package or namespace load failed for ‘dplyr’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
there is no package called ‘Rcpp’"

But when I try to install Rcpp it does not fix the problem.

Please help!

Sorry about the trouble you're having.
Sharing your Rcpp installation attempt error messages would be helpful.

Rcpp occasionally has trouble installing because a C++ compiler isn't present on your machine. If that's the case, the complier you need to install depends on your OS

  • On Windows, install Rtools.
  • On Mac, install Xcode from the app store.
  • On Linux, sudo apt-get install r-base-dev or similar.

However, the above advice is just guess, knowing a bit more about the errors you're receiving the system you're on would be helpful.

Hey @akarabou, I was facing the same issue and I found that it basically couldn't install the update for Rcpp for some reason. What worked for me is: when installing the dplyr package, it was prompting me wether I wanted to install the update version of Rcpp, and I found that every time I responded yes it didn't work. So when installing again I replied no, and it installed the previous version of Rcpp which worked! Give it a go, and let me know if it works! Good luck!

That worked! Thanks. Just needed to say "no" to Rcpp.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.