Error: The Rstudio server is taking a long time to respond. It is possible your R session has become unresponsive. Do you wish to terminate?"

Hi There, I have packaged and installed R and Rstudio for users in my environment. It works for most but I have a bout 5 users who when launching Rstudio it just loads and then eventually the above stated error appears. I Can replicate the issue but only if Rstudio is launched before R3.4.4 is launched/installed.

The folder structure created in the R state file is incomplete and missing - Client state, PCS, Viewer-cache, admin registry, rmd-outputs and saved_source_markers

RSession log file: 29 May 2018 05:51:16 [rsession-userid] WARNING Abort requested; LOGGED FROM: bool rstudio::session::connection::checkForAbort(rstudio_boost::shared_ptrrstudio::session::HttpConnection, rstudio_boost::function<void()>) C:\Users\Administrator\rstudio\src\cpp\session\http\SessionHttpConnectionUtils.cpp:137
Renamed state file - issue still occurs
Uninstalling does not remove the r desktop state file.


Re-Profiling user seems to delete all associated files, but only after uninstall and registry removal.
Issue still occurs after re-profile.
Have White listed and tested new version of Rstudio 1.1.45, same issue occurs.

Any help would be appreciated!

I don't quite understand what this means -- presumedly, R and RStudio should both already be installed before attempting to launch RStudio, and RStudio will attempt to discover + use R when it is launched.

Can you elaborate a bit further?

Hi Kevin,

this is correct they should both be installed via our software centre where I have deployed them, before launching. However the users have mis-understood the instructions for installation. So the affected users have launched Rstudio before installing R. Unfortunately an uninstall and or troubleshooting listed above hasnt remedied the issue.

For me, on Windows, it worked to go to C:\Users\my_user\AppData\Local\RStudio-Desktop\sources and delete the "strange" folder named 's-DDDLLDLL' (being D different digits, and L different letters).
Previously, deleting all .data and session files all around my HDD hadn't worked.