Error Starting R on Mac

All of a sudden, RStudio is not able to start R. Just did a Mojave system update to OSX 10.14.6. R version is 4.02. Reinstalled RStudio just to be sure. R starts up just fine on its own.

I get the following error when starting RStudio:

Error Starting R

The R session failed to start.


[No error available]


The R session process exited with code 6 .


dyld: Symbol not found: _GEkillDevice Referenced from: /Applications/
Expected in: flat namespace
in /Applications/`


[No output emitted]


Log File [No logs available]

See the only other thread on this issue that I've found. If you have ever installed R using brew, that's likely to be the culprit.

I have not used Homebrew for R or RStudio. I always install RStudio and R updates by hand rather than through Homebrew. I install R from a CRAN repository.

This happened quite suddenly after the latest Mac system update. I can't help but think it is somehow related. I can't think of anything else I changed that might have caused this.

Have you updated XCode? Did you runs the command line checks in the linked thread? Catalina and R4.02 and RStudio's current release play well together on my 2015 Airbook, so it seems likely that it is a system library problem.

I have the latest version of XCode for Mojave. Nothing has changed since two days ago when everything worked. The only intervening event is the automatic security upgrade to OSX.

Let me explain precisely what happens when I try to start RStudio: A window opens with the error message. (I have uploaded an image of the window.) There is no debug information, no chance to load RStudio for debugging. Nothing. Just the error window. When I close the window, RStudio closes.

Again, I have updated R and do not have redundant installations. R runs fine either from or from Terminal.

  1. macOS should be 10.15.5, not 10.14.6
  2. XCode should be 11.6 (11E708)
  3. Rstudio should be 1.3.959
  4. R should be at 4.02

If macOS, XCode, RStudio and R are not at these versions, they must be all at previous versions that sync up.

The error message is obscure. GEkillDevice been reported on RStudio with iMac in the thread referenced, in connection with the Slackbuild package manager and in R.2.7.0. Beyond this only a handful of other posts reference it.

If R was installed on a user level, rather than in /Library/Frameworks/R.framework the error might occur.

My suggestion is to upgrade all the environment to the versions above, taking care to install R from the notarized package on CRAN for all users.


  • macOS Catalina v10.15.6
  • R v4.0.2
  • RStudio v1.3.1056
    Same issue as @bshobe. R works just fine.
1 Like

Thanks for the report. Is R installed in /Library/Frameworks, which required root privileges to install? Or was it installed in a user directory?

My R is installed in /Library/Frameworks.

1 Like

It seems there was an issue with Cylance rather than just notifying that RStudio was "trying an exploit", it treated the new version more harshly and blocked access that it needed. Just quitting the app is not enough, you have to uninstalled Cylance completely. Installing it back afterwards should allow you to use both.

then it will go back to just alter

Violation: DYLDInjection; /Applications/

Any slight chance you're also using Cylance?

Yep. I am. I will try @Nosferican's proposed fix.

1 Like

Great! If that works, please circle back and mark a solution.

It worked. Yea!

I uninstalled Cylance and reinstalled R and RStudio. Now RStudio works. Thanks all.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.