"Error Starting R" on 2021 MacBook M1 Pro

This story starts with my old laptop. I installed R and R studio on my old laptop (2015 MacBook Pro), and through my best efforts I was never able to get it to work. I could launch R, but RStudio would show as running in the top left of the Mac, but no UI showed up at all. I uninstalled and reinstalled R and R studio and then it led to RStudio Launching with no errors and no logs. It just failed. I gave up on it until this last week when I bought a M1 Pro MacBook Pro. Knowing that it is ARM64 not x86 I installed all the appropriate installers for MacOS ARM64 devices. Once again, R launches correctly and I can use it as an app and it launches within the terminal, in both locations I can use R as expected. I launch RStudio and it is the same error as the old computer. Note: I did use Mac OS' "Migration Assistant" to get all my old files onto the new computer, so my best guess is that something that is in the files from the old computer is causing it not to work. I have deleted all R and RStudio related files and applications and did a fresh install and I still get the same fatal error with no details. Please see screenshot below:

Any advice on this problem would be greatly appreciated. I have wasted many hours on this issue over the last couple of months and I really just need this up and running.


I have no idea how or why this works, but I can indeed confirm that RStudio now works on my main account. If you run into this same errorless error then you're in luck because the fix is not that horrible.

  • Create a new account and open that user account launch RStudio (it should work. If not you probably have a different problem)

  • Once you launch it just do something really simple like in the terminal x <- 5 or something like that

  • go ahead and close it and log back into you main account

  • open your main drive in finder and make hidden files shown (command+shift + . )

  • navigate into the user folder of the new account that you made find all RStudio related files in this folder.

  • Copy over all the files that have to do with R and RStudio into their respective directories in you User folder. The ones folder that I think did it was in .local/share/RStudio however I did move over everything, it was just not until I properly brought over that share folder inside the .local did it work.

Once I did that I launched RStudio and for the first time in about a year I finally have RStudio working on one of my own devices. Hope this can help someone in the future.

Have you installed Rosetta?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.