Error starting IDE without internet connection (Desktop) SOLVED

When starting RStudio without internet connection i get an error:

ERROR asio.netdb error 1 (Host not found (authoritative)); OCCURRED AT rstudio::core::Error rstudio::core::http::initTcpIpAcceptor(rstudio::core::http::SocketAcceptorService<rstudio_boost::asio::ip::tcp>&, const string&, const string&) src/cpp/session/http/SessionPosixHttpConnectionListener.cpp:88; LOGGED FROM: int main(int, char* const*) src/cpp/session/SessionMain.cpp:2302

I tried by removing the config files etc. but it doesn't work.
I also tried upgrading to the last version, still the error appears, if I am not connected to internet.
My OS id Debian stable with Cinnamon DE

RStudio 2023.12.1+402 "Ocean Storm " (4da58325, 2024-01-29) for Ubuntu Focal

Without any action from my side, the problem has solved. Cannot say exactly how...

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.