Error: package 'Rcpp' does not have a namespace when trying to knit a notebook.

I have been trying to knit a workbook together but when I do this I get the error

Error: package 'Rcpp' does not have a namespace

There was a similar post recently however I tried what they said worked and didn't get anywhere with me.

Thanks in advance for any help!

When I try to reinstall it as suggested in the post I get this error

> install.packages("Rcpp")
Installing package into ‘D:/Documents/R/win-library/3.6’
(as ‘lib’ is unspecified)

  There is a binary version available but the source version is later:
      binary source needs_compilation
Rcpp  1.0.5              TRUE

installing the source package ‘Rcpp’

trying URL ''
Content type 'application/x-gzip' length 2950521 bytes (2.8 MB)
downloaded 2.8 MB

* installing *source* package 'Rcpp' ...
** package 'Rcpp' successfully unpacked and MD5 sums checked
ERROR: cannot remove earlier installation, is it in use?
* removing 'D:/Documents/R/win-library/3.6/Rcpp'
* restoring previous 'D:/Documents/R/win-library/3.6/Rcpp'
Warning in file.copy(lp, dirname(pkgdir), recursive = TRUE, = TRUE) :
  problem copying D:\Documents\R\win-library\3.6\00LOCK-Rcpp\Rcpp\libs\x64\Rcpp.dll to D:\Documents\R\win-library\3.6\Rcpp\libs\x64\Rcpp.dll: Permission denied
Warning in install.packages :
  installation of package ‘Rcpp’ had non-zero exit status

The downloaded source packages are in

Solved by deleting the Rcpp folder in my library manually and then reinstalling Rcpp. Seems like I have some windows permissions problems with my library.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.