Error: package or namespace load failed or 'usethis':

I have a problem opening a graph from an external software. I worked in my old laptop, but not this new one.
It would normally display the graph, but what I received by far is an error message (see below).

I tried to install 'usethis', 'rlang', and 'tidyverse'. The installation seemed to be successful, but when I called using library, there were error message saying the package load failed. I even tried to uninstall and reinstall R software. I have R for Windows 4.0.3 on my institute software catalogue.

Error: package or namespace load failed for ‘usethis’:
.onLoad failed in loadNamespace() for 'rlang', details:
call: NULL
error: The rlang package is not properly installed.
The DLL version does not correspond to the package version.
Please update rlang to the latest version.
Updating packages on Windows requires precautions:
[Previously saved workspace restored]

Please help.


Have you tried removing and reinstalling rlang?

Hi Andresrcs,

Thank you for your reply.

I couldn't remove nor reinstalling rlang. When I library(rlang) it is not in my R.

Anyway, I googled for more in the Rstudio Community and tried to install rtools. It works like a magic because I can now install usethis and rlang. I can get the graphs I wanted too. It works seamlessly.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.