Error: option error has NULL value on version 3.6.1

Updated to Action of the Toes 3.6.1 yesterday- running on the latest Rstudio. Updated all packages, RStudio, and OS X. In addition to the error, it is killing my battery, needs to be manual quit, and doesn't respond to exit.

Homework is due Tuesday and the only suggestion I've received is to uninstall. Note I am not a programmer. I did google it but didn't find much support.

Thank you!

Description of issue -

System Information:

  • RStudio Edition: (Desktop or Server)
  • RStudio Version:
  • OS Version:
  • R Version:
  • sessionInfo():

Referred here from

Could you explain on what circumstances do you get that error message? Is right after you start Rstudio or while running a specific command?

In the first chunk loading packages and calling data frame.

To help us help you, could you please prepare a reproducible example (reprex) illustrating your issue? Please have a look at this guide, to see how to create one:

@NH102 in this case, that will be the smallest amount of code that produces the error. Is it one library statement? Two? More? Does the error not happen until you try to import data? You may need to run line-by-line to figure this out.

If the error only happens when you are importing data from somewhere on your computer, then it won’t be possible to make an entirely reproducible example, but seeing the code may still help.

It will also help to see the entire error message in the context in which it occurs (it’s usually a bit surprising for people to learn that error messages on their own aren’t often very useful! It’s the error plus the code that triggered it that starts to give you clues).

I also ran into this issue with RStudio 1.2.1335 on Mac with R 3.6.1. @NH102 it would help everyone help you if you filled out the System Information section with your RStudio, OS, R version etc. Do you set any options in your ~/.Rprofile or in the setup chunk of your R Markdown document?

One potential fix (that also worked for me) is to download and install the preview version of RStudio v1.2.1578-2 from

1 Like

Thank you that fixed it! I was running on RStudio 1.2.1335 with 3.6.1 and OS 10.13.16.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.