Error on using install.packages command!

Hi, I have been trying to install packages in R version 3.6.1 (2019-07-05) like "dplyr" and "readxl".
Command :install.packages("dplyr")
Observation: I can see the download happening with some warning messages in the console video as given below.

trying URL ''
Content type 'application/zip' length 3266314 bytes (3.1 MB)
downloaded 3.1 MB

package ‘purrr’ successfully unpacked and MD5 sums checked
Error in install.packages : ERROR: failed to lock directory ‘E:\R-3.6.1\library’ for modifying
Try removing ‘E:\R-3.6.1\library/00LOCK’

Next when I call the library function another error pops up as shown below:
Error in library(dplyr) : there is no package called ‘dplyr’.

Tried installing packages using Install Packages window, same error repeats.

PS: This did not happen during installing readr packages.

Thank you in advance for your valuable comments.

The error message is self explanatory, have you tried following its advice and deleting the LOCK file?

1 Like

Thank you so much. I started using R since last Friday. Still getting used it.
Back on track.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.