Error on rendering quarto tutorial document

I have been following this tutorial to use quarto in Rstudio: Quarto - Tutorial: Hello, Quarto
However, I ahave been unable to go past the third step, as when I click on Render, I consistently get the same error:
Error: invalid version specification 'find'
In addition: Warning message:
In system(paste(shQuote(path), "--version"), intern = TRUE) :
running command '"C:/PROGRA~3/CHOCOL~1/bin/pandoc.exe" --version' had status 65535
Execution halted

I am using Rstudio version 2023.06.1. There is a quarto folder within the bin of Rstudio.

I have tried many things, such as uninstalling Rstudio and quarto and reinstalling them, same for pandoc. I have looked at similar errors but I haven't found anything that solved this one. I would appreciate any help.

Thank you.


It seems some of the tools are installed using Chocolatey maybe ?

It seems to me that somehow your Pandoc version used cannot be ran. Can you check which tools are used ? How are they installed ?

Hi thanks for answering.
Since I posted this message, I reinstalled R-studio and R. I was still getting the same error and when typing rmarkdown::pandoc_version(), I was also getting "Error: invalid version specification 'find'".
Finally I opened command window as admin and ran choco install pandoc --force and this actually works, I am now able to have renderings of my quarto files.
To answer your question: yes I used chocolatey to install some of the tools.
Thanks a lot for your answer and help!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.