Error on opening RStudio

When RStuio opens, it says, "Error in .rs.parsePackageDependencies(contents, extension) : object 'partition_yaml_front_matter' not found". I seem to have the latest RStudio, R and all contributed packages. See below.

R version 4.2.1 (2022-06-23) -- "Funny-Looking Kid"
Copyright (C) 2022 The R Foundation for Statistical Computing
Platform: x86_64-apple-darwin17.0 (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

Natural language support but running in an English locale

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

Error in .rs.parsePackageDependencies(contents, extension) :
object 'partition_yaml_front_matter' not found

R version 4.2.1 (2022-06-23)
Platform: x86_64-apple-darwin17.0 (64-bit)
Running under: macOS Big Sur 11.6.7

Matrix products: default
LAPACK: /Library/Frameworks/R.framework/Versions/4.2/Resources/lib/libRlapack.dylib

[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats graphics grDevices utils datasets methods
[7] base

loaded via a namespace (and not attached):
[1] compiler_4.2.1 fastmap_1.1.0 cli_3.3.0
[4] htmltools_0.5.2 tools_4.2.1 rstudioapi_0.13
[7] yaml_2.3.5 rmarkdown_2.14 knitr_1.39
[10] xfun_0.31 digest_0.6.29 rlang_1.0.4
[13] evaluate_0.15

1 Like

See Error in .rs.parsePackageDependencies(contents, extension) : object 'partition_yaml_front_matter' not found after update to R 4.2.1 · Issue #11552 · rstudio/rstudio · GitHub as suggested by @HanOostdijk in another thread.

Try closing RStudio, deleting the file .Rproj.user in the home directory, and restarting.

Worked for me, anyway.

Thanks. it worked. sg

Try opening several Rmd files, quit R and then relaunch. Does the message reappear? The number of times the message appears for me is the number of open files minus one. I can get it to stop by disabling Tools > Global Options > Code > Diagnostics > Prompt to install missing R packages discovered in R source files.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.