Error not printing in Rstudio

I am relatively new to R, I am trying to run some scripts in r studio but I noticed that errors are not being printed even when the code is problematic. The simplest example is the following: in an empty environment, I type "print(a)" and I expect an error saying "Error in head(a) : object 'a' not found", however nothing pops up in my R studio. I am able to get this error in R but not R studio. I am running Studio on a Mac computer.

> print(a)
Error in print(a) : object 'a' not found

is exactly what I get in RStudio
Ubuntu 20.10; R 4.0.3; Rstudio 1.4.1100

Yes, the problem explained above is that I am not getting any errors whatsoever. So when i run more complex commands and I don’t get an output, I don’t know how to fix it, since I don’t get any error messages

You are most likely entering the code into the source window (by default top left), but not sending the commands to the console (by default bottom right).

Use the Run button or hit Ctrl+Enter.

1 Like

I was just confirming that you had a problem. I suspect it is a problem with the desktop profile but I have no idea of even how to find it. clearly my google skills are deficient.

Sorry to have been of no help.

I am definitely entering my code into the correct window (The console):grinning:. Furthermore, if I run R via the terminal through R studio I run into the same problem, but if I run R independently (outside of Studio) I don’t have the ‘missing’ error problem, which leads me to think it’s specifically an R studio problem.

Thank you so much for trying. :raised_hands:t5:

Exactly, my post was incomplete. I meant an RStudio profile. I have seen references to it in this forum but cannot find them and searching around on my system has not turned up any suspicious characters.

I may not even be using the correct terminology. I am used to seeing profile problems with the Apache OpenOffice suite and I may be mixing up my terms. Sorry to sound like such an idiot.

I may have stumbled over a lead.

Where else RStudio searches for rstudio-prefs.json?

I may have been thinking about rstudio-prefs.json

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.