Error message when loading 'swirl' package

I am able to install the 'swirl' package, but when I try to load the library, I receive the below error message. Any help you can provide as to how I may fix this is appreciated.

Error: package or namespace load failed for ‘swirl’ in namespaceExport(ns, exports):
undefined exports: AES, digest, digest2int, getVDigest, sha1, sha1_attr_digest, sha1_digest, hmac, makeRaw
In addition: Warning message:
S3 methods ‘print.AES’, ‘sha1.anova’, ‘sha1.array’, ‘’, ‘sha1.character’, ‘sha1.complex’, ‘’, ‘sha1.Date’, ‘sha1.default’, ‘sha1.integer’, ‘sha1.factor’, ‘sha1.formula’, ‘sha1.function’, ‘sha1.logical’, ‘sha1.list’, ‘sha1.matrix’, ‘’, ‘sha1.NULL’, ‘sha1.numeric’, ‘sha1.pairlist’, ‘sha1.POSIXct’, ‘sha1.POSIXlt’, ‘sha1.raw’, ‘sha1.(’, ‘makeRaw.default’, ‘makeRaw.digest’, ‘makeRaw.character’, ‘makeRaw.raw’ were declared in NAMESPACE but not found

I was able to install and load the "swirl" library without any problems.

Two checks for you, for a start:

  1. Are you sure you did not get error messages when installing "swirl" concerning certain libraries that were missing or superseded in version?
  2. Did you try and install "swirl" in a new R session? If not, try that and see if it helps.


When installing, I receive the message that 'swirl' was successfully unpacked and MD5 sums checked, so I don't think I'm missing anything there. And I just tried installing and loading into a new R session and am still getting the same error message.

Then I am not sure what the problem is. The "swirl" dependencies are quite light.

Assuming you have a recent version of R, you could try installing from github, as in the FAQ (see swirl | FAQ ( No guarantees, but it might work. Other than that, I'm afraid you might have to talk to the "swirl" people via swirl: Learn R, in R. (


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.