Error loading Package R 4.0.0 and RStudio 1.2.5042


I updated both, my programs and packages to the latest version, but it happens, that when it is in the process of updating the packages appear a error saiyng about warning of Rtools is not installed, like in the image.

The package as such gets installed but when I try to open its library apper another error saying that this package it is not found, like this error.

¨Error: package or namespace load failed for ‘ggplot2’ in get(Info[i, 1], envir = env):
file could not be opened 'C:/Users/elias/Documents/R/win-library/4.0/rlang/R/rlang.rdb': No such file or directory¨

I have seen some forums saying that I must restart the R session, others like: RTools: Toolchains for building R and R packages from source on Windows I have tried to do it. I open de the bash and write in screen as same as appers in this link, but I do not occur nothin, what I should do here.

Have you tried reinstalling rlang package?

About the RTools message, this is only required if you are going to install packages from source, if you are choosing to install binary versions then you should be OK.

Same thing

That problem is because you have a non-ASCII character (i.e.í) and an empty space in your windows user name, either try to install on the system level package library rather than the user level one, or change your user name.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.