Error installing Rtools

First post, thanks in advance for any help provided!

I'm trying to install rtools on a Windows 10 machine and I'm not sure its installing correctly. I'm following these instructions: 1.1 Installing On Windows Machines | Data Science Labs’ Programming Guides

I get an error when I attempt the following: installr::install.rtools()
so I installed from here:

If I check my installation, I get the following error:

Error: 'find_rtools' is not an exported object from 'namespace:devtools'

If I check it another way it looks like it's installed:

[1] TRUE

Since I did not get a TRUE or FALSE (only an error) I did try to edit the path variables, deviating slightly from the instructions due to newer Rtools version:

I am still getting the same error when I run devtools::find_rtools()
Error: 'find_rtools' is not an exported object from 'namespace:devtools'

The find_rtools() function lives in the covr package.

Not sure if the function was moved in the recent big devtools update.

Thank you so much for your response, I'll have to check that out!

The page you link to is covr version 1.2 and covr is now in 3.2.1. So it is pretty outdated. In the current covr version, there is no find_rtools function.

Those function about rtools were moved from devtools to pkgbuild during the refactoring for devtools 2.0. See the NEWS file.

See also the blog post about new devtools to see other changes


@cderv I even checked that NEWS file. No idea how I missed that. Thanks for the catch

1 Like