Error installing arulesViz package

I tried to install arulesViz package but ended up with below error. I even tried installing TPS and data.table packages referring to a previous thread but could not succeed.

  • installing source package 'arulesViz' ...
    ** package 'arulesViz' successfully unpacked and MD5 sums checked
    ** R
    ** inst
    ** preparing package for lazy loading
    Error in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]) :
    there is no package called 'dendextend'
    ERROR: lazy loading failed for package 'arulesViz'
  • removing 'C:/Users/venka/Documents/R/win-library/3.4/arulesViz'
    Warning in install.packages :
    running command '"C:/PROGRA~1/R/R-34~1.4/bin/x64/R" CMD INSTALL -l "C:\Users\venka\Documents\R\win-library\3.4" C:\Users\venka\AppData\Local\Temp\RtmpwLUeQZ/downloaded_packages/arulesViz_1.3-3.tar.gz' had status 1
    Warning in install.packages :
    installation of package ‘arulesViz’ had non-zero exit status

The downloaded source packages are in

The error message is telling you that you are missing this dependency, try installing it first


Hi Andre,

Thanks for your reply. I even tried installing dendextend and it too failed with missing ggplot2. Then I installed ggplot2 and it too failed to install. Almost all had same error message. Any clues?

The only solution is to solve the missing dependencies, they are not the same for all packages. As a shortcut try with

install.packages("tidyverse", dependencies = TRUE) 

If you get any more error messages please post them here, we can't help you without information.

Had the same issue on MacOS. The below steps fixed it. It might work on Windows as well.
Try out the following steps:

  1. Go to site-library folder where R is installed (also make sure to change version from 3.6 to whatever you have) - R/3.6/site-library/
  2. In the site-library folder, remove the directory 00LOCK-igraph ( I used rm -r 00LOCK-igraph)
  3. Install package TSP
  4. Install package data.table
  5. Install package arulesViz

Hope this helps!

I had the similiar issue and I installed the latest R version 3.6.1 and was able to install the package arulesViz successfully. Give it a try.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.