Error Installing arulesViz after 3.5.0 update


I am getting the attached error when I attempt to install the arulesViz package by running the following command in RStudio.

I tried with the dependencies parameter set to TRUE and received the same error.

Any help would be appreciated. Thank you in advance.

install.packages("arulesViz", dependencies=TRUE)

Can you try installing TSP package?

I'm having the same problem and i've try to instal TSP but I have this message from r:

Package wich is only available in source form, and may need complitaion of c/c++/fortran: 'TSP'
These will not be installed.

Thank you for response. Below is the error I am getting when I attempt to install TSP package.
I Install_TSPError

You may need RTools 3.5 first before you can compile package from source


Thanks a million! This worked very well.
In addition to TSP package, data.table is another package that had to be installed from the source for the arulesViz installation to work.

If your question's been answered, would you mind choosing a solution? (see FAQ below for how) It makes it a bit easier to visually navigate the site and see which questions still need help.