Error in View : Object 'chapter1' not found / Is this a valid Excel file?

I'm a newbie and have troubles importing an Excel to RStudio (Import Dataset; From Excel).
(as you can see below, the same error message always pops up)
There should be no issue with the Excel file, I can open it without any problems. Maybe it's the file name or the fact that it's saved on One Drive?
There are no updates possible for the packages, not even for the entire RInstallation.
The package "readxl" is installed but have to be ticked every single time as soon as I open RStudio.

Any help would be really appreciated! (FYI: I'm using Windows 10)
Thanks :slight_smile:

Try saving it to your desktop (or anywhere that is not OneDrive/Dropbox, etc.) and opening it from there.

Even better, use a project:

You could also specify the sheet name in read_excel() and see if that helps.

Thank you for your answer!

I tried it multiple times to save the file on Desktop.
In addition, I have now deleted/disconnected the link to OneDrive, but it still does not work, as you can see on the screenshot...

That error message really gives the impression that you are not reading a true Excel file. Did you create it or did it come from somewhere else?

Excel is rather notorious for labelling things that Excel and only Excel can open as if it were an Excel file.

You might try exporting a sheet as a .csv file and try loading that with read.csv or read_csv.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.