Error in Oauth2.0 authentication in using HTTR (failed to connect: connection refused)

I am trying to create a simple app (in R) using GroupMe's API, which utilizes OAuth2.0. The documentation can be found here. However, I'm getting stuck on the first step of authentication/token generation for a user. See below for my code and the response I get:

access_key = ****
client_id = ****

gendpoint <- oauth_endpoint(
  authorize = glue("{client_id}"),
  access = glue("http://localhost:1410/?access_token={access_key}")

gapp <- oauth_app(
  key = client_id,
  secret = access_key

t <- oauth2.0_token(
  endpoint = gendpoint,
  app = gapp

The above code is sufficient to bring in the login page, which presumably allows me to enter my credentials to obtain a token. However, when I enter my credentials, I get the following error message in R:

Authentication complete.
Error in curl::curl_fetch_memory(url, handle = handle) : 
  Failed to connect to localhost port 1410: Connection refused

So it looks like my authentication/login credentials worked, but somewhere an error prevented me from actually generating the token.

Could someone help me with this? So far I've tried reinstalling the curl package, to no avail. This is my first time using the OAuth2.0 framework so I'm very confused. Thanks in advance!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.