Error in installing ggbiplot

I am trying to install ggbiplot from githubb
Three days ago, I did not any anny issues with this. I was able to download and load this library.
After re-installing R and Rstudio, I am getting following messages.
Could you help me please

Downloading GitHub repo vqv/ggbiplot@master
WARNING: Rtools is required to build R packages, but is not currently installed.
Please download and install Rtools 3.5 from
√ checking for file 'C:\Users\ar02\AppData\Local\Temp\Rtmp63ASuz\remotes32f4209263dc\vqv-ggbiplot-7325e88/DESCRIPTION' (5.6s)

  • preparing 'ggbiplot': √ checking DESCRIPTION meta-information ...
  • checking for LF line-endings in source and make files and shell scripts
  • checking for empty or unneeded directories - looking to see if a 'data/datalist' file should be added - building 'ggbiplot_0.55.tar.gz' Installing package into ‘\’ (as ‘lib’ is unspecified) '\\DEDJTR\HomeDirs2\ar02\Documents' CMD.EXE was started with the above path as the current directory. UNC paths are not supported. Defaulting to Windows directory. ERROR: failed to lock directory '\' for modifying Try removing '\' Error: Failed to install 'ggbiplot' from GitHub: (converted from warning) installation of package ‘C:/Users/ar02/AppData/Local/Temp/Rtmp63ASuz/file32f428716b5b/ggbiplot_0.55.tar.gz’ had non-zero exit status

Have you tried following this instructions? you need to install Rtools for compiling packages on windows.

Thanks, Andresrcs
Yes, I have tried this method too.
I have install Rtools and then tried to instal ggbiplot.
I got exactly same error message as before except the message which relate to Rtools.

Is this the path of a network drive? If so, could you try installing into a local path?

Hi Adresrcs
Thanks for you help.
As per your advice, I have installed Rtools then used following command to install ggbiplot in local directory

.libPaths( c("C:/Data/R_Package/Library", .libPaths() ) )

Then I used following commands to install ggbiplot


It worked OK

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.