Error in installing dyadr package

Error Information:

Description of issue -
There is an error in installing "dyadr" package in r

Steps taken so far -
If I ran the command "devtools::install_github("RandiLGarcia/dyadr")", then the message like "Error: Failed to install 'dyadr' from GitHub:
(converted from warning) cannot remove prior installation of package ‘rlang’" appeared during the process and it stopped. After that, if I ran the command such as "library(dyadr)", then the error like "Error in library(dyadr) : there is no package called ‘dyadr’" and I cannot run any analysis under dyadr package in R.

System Information:

  • RStudio Edition: Desktop
  • RStudio Version: Version 1.2.1335
  • OS Version: Windows10
  • R Version: 4.0.2 (2020-06-22)


  • RStudio diagnostics report:
  • Your sessionInfo():
  • RStudio crash report:
  • RStudio application log files:

From Troubleshooting Guide: Using RStudio

I feel, you need to remove first all of dyadr package dependencies first, in this case is rlang, and other package which gives this error, this is commonly happen to me also for some package outsourced from Github.

Go manually to your R Libraries folder and delete which package causing the errors

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.