Error emptying the trash in

When I try to empty the trash in my Workspace in I get an error:
Error Emptying Trash

Sorry, we were not able to completely empty your trash.

Error Emptying Trash

There are two untitled projects in the Trash. It seems to run into issues with those. When I try to restore them I get this error:

Task 549498029 failed: Unhandled Exception: Child Task 549498030 error: Unhandled Exception: {"message":"VolumeDriver.Mount: Error mounting volume_name='volume-278297': Failed to map image='b9e15ac2-ea0c-4e44-a086-4ffcaf55461c': Error running command: 'sudo -u root rbd nbd map

Task 549498057 failed: Unhandled Exception: Child Task 549498061 error: Unhandled Exception: {"message":"VolumeDriver.Mount: Error mounting volume_name='volume-278345': Failed to map image='b96d5fa7-d91a-46e8-bfa3-405b65dd563b': Error running command: 'sudo -u root rbd nbd map

Any suggestions on how to clear these? Thank you in advance.

Any updates? I am not sure how to clear this issue. There's clearly some technical issue with my workspace. Thank you.

Hey @gevorg, I'm sorry you haven't heard back from anybody! I'll flag this thread and see if we can get some eyes on it :slightly_smiling_face:

Thank you so much. I have been avoiding using the and just sticking with Rstudio on my laptop because of this. Really appreciate your help getting this resolved. Please let me know if there's some way for me to fix it myself.

Tiny reminder: RStudio Cloud is still an alpha product (= even earlier in development than a beta), so I think you should expect there might be bumps in the road and definitely make sure to back up any important work elsewhere (or don’t use it for important work yet β€” your call!).

1 Like

Yes. Understood. It would still be great if the issue could be resolved. It seems to me some disk issues behind the scenes in the containers. Many thanks.


I should have added that on the flip side, given the early development phase, reporting problems is very helpful! :grin:


I should add a bit more information in case this helps. We're using Rstudio as part of our analytics program at Harvard (Harvard Business Analytics Program). I remember a couple months ago (around July 26, 2018) there were a couple days when everyone in my cohort seemed to have issues using The system was unavailable. The environment was down and my professor said he had contacted someone at the company. service was restored but since then I started running into this issue. Thanks again.

We will try to get this sorted out in the next week or so. Our apologies.

1 Like


I went in and manually unstuck these volumes. Can you try deleting the project again?



Thank you Andy. In my case the projects are in the Recycle bin and I can neither delete them nor restore them. Unfortunately I just tried that action again and with the same result.

Task 557614516 failed: Unhandled Exception: Child Task 557614520 error: Unhandled Exception: {"message":"VolumeDriver.Mount: Error creating mount record for volume='d4b3ca6f-a8d7-4127-804f-e99f68a6c6b2': HTTP 400: Unable to mount

Oh dear. Can you send me the project ID or URL for the project you are attempting to delete? I'd like to take a closer look to determine why these are not deleting. You can DM me if you prefer.

1 Like

Hi Andy, I don't know how to get the project IDs. I cannot restore these projects from Trash or delete them from there. Is there any secure way for me to provide my ID/pw so you could see the issue and help troubleshoot? Thank you.

It looks like this for me.

That's okay. If you head to the "account" page on the right hand nav menu, you can send me your account ID. I can take it from there.

Thank you Andy. Id is 138746. Please let me know if you need anything else.

I just wanted to follow up on this. Did you have a chance to take a look? Thanks so much!

I'll try to pick up where Andy left off later today.

Thank you Josh. Really appreciate you looking into this.

Josh, Andy, Any luck looking into this issue for me. Thank you.

I unstuck several of the projects' problematic volumes, but possibly not all of them. Could you please try again and let me know what happens?

1 Like