Error: could not find symbol "values" in environment of the generic function

I'm trying to run the grid_metrics function from the lidR package and have suddenly been stopped by the following error message:

"Error: could not find symbol "values" in environment of the generic function"

I have tried to uninstall and re-install the lidR package, R, and RStudio. I have also tried to load older versions of the package and R that I can confirm do work for this code and dataset using other computers. Hoping for any advice for other things to try.

ctg <- readLAScatalog("G:\Test_ALS_processing\1_PreProcessing\ALS\data\norm_nb")

Prj <- "+proj=utm +zone=10 +datum=WGS84 +units=m +no_defs +ellps=WGS84 +towgs84=0,0,0"
projection(ctg) <- Prj

opt_output_files(ctg) <- "" ## this is where plot las files will be saved
opt_filter(ctg) <- "-drop_z_below 0, -drop_z_above 45"
opt_filter(ctg) <- "-drop_withheld"
opt_chunk_buffer(ctg) <- 10 # Buffer size
opt_chunk_size(ctg) <- 250
ctg@output_options$drivers$Raster$param$overwrite <- TRUE
opt <- list(raster_alignment = 10, automerge = TRUE)

rumple_metric <- grid_metrics(ctg, ~rumple_index(X,Y,Z), res = 10)


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.