ERROR Cannot connect to the Job Launcher service && [rserver] ERROR system error 111 (Connection refused);

Hi, I am trying to integrate RStudio Server Pro with Launcher and Kubernetes, both launcher and RStudio Server Pro services reside on the same ubuntu virtual machine on our Azure cloud environment.
I followed the RStudio documentation( and configured all the necessary things as per the document.

When I execute the below command.
sudo rstudio-server verify-installation --verify-user=

And I got the following error:

Checking Job Launcher configuration...
Ensuring server-user is a Job Launcher admin...
03 Apr 2020 17:14:01 [rserver] ERROR Cannot connect to the Job Launcher service; LOGGED FROM : rstudio::server::session_proxy::overlay::{anonymous}::ensureServerUserIsLauncherAdmin()::_ _lambda2 /var/lib/jenkins/workspace/IDE/pro-pipeline/v1.2-patch/src/cpp/server/JobLauncherVe rification.cpp:159
03 Apr 2020 17:14:01 [rserver] ERROR system error 111 (Connection refused); OCCURRED AT: voi d rstudio::core::http::TcpIpAsyncConnector::handleConnect(const rstudio_boost::system::error _code&, rstudio_boost::asio::ip::basic_resolver<rstudio_boost::asio::ip::tcp>::iterator) /va r/lib/jenkins/workspace/IDE/pro-pipeline/v1.2-patch/src/cpp/core/include/core/http/TcpIpAsyn cConnector.hpp:197; LOGGED FROM: int main(int, char* const*) /var/lib/jenkins/workspace/IDE/ pro-pipeline/v1.2-patch/src/cpp/server/ServerMain.cpp:581

And also I tried the following steps to troubleshoot this issue:

  1. Ensure that the Kubernetes CA certificate is not base64 encoded and that it starts with -----BEGIN CERTIFICATE----- .

  2. Ensure that you've added the Kubernetes CA certificate to your system certificate chain by placing the certificate file in /usr/share/pki/ca-trust-source/anchors/cert-eks-cluster.crt (on RHEL/CentOS) or /usr/local/share/ca-certificates (on Ubuntu). Then run sudo update-ca-trust (on RHEL/CentOS) or sudo update-ca-certificates (on Ubuntu).

  3. Skip the CA certificate verification by adding verify-ssl-certs=0 to /etc/rstudio/launcher.kubernetes.conf , then restart rstudio-server and rstudio-launcher and start a new session. Note that for production use, you should always have this enabled, but it can be disabled for testing purposes.

None of the above steps works for me, I am still receiving the same error.

Any help would be greatly appreciated.

Hi @umeshtharun,

If you haven't already, I would suggest you reach out to RStudio Support, as they can help you with this issue.

Here are details on how to submit a ticket:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.