dplyr does not compile.

I am trying to install "dplyr" in a complete new fresh project at it fails with this error.

3.6/Rcpp/include" -I/usr/local/include  -fpic  -g -O2  -c mutate.cpp -o mutate.o
g++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-5/README.Bugs> for instructions.
make: *** [mutate.o] Error 4
/opt/R/3.6.0/lib/R/etc/Makeconf:176: recipe for target 'mutate.o' failed
ERROR: compilation failed for package ‘dplyr’
* removing ‘/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.6/dplyr’
Warning in install.packages :
  installation of package ‘dplyr’ had non-zero exit status

It is failing in this project:



fyi: I'm having the same error - both for CRAN and GitHub installing.


Because of the US holiday, we had a bit of extra sluggishness in ensuring dplyr 0.8.3 hit the package cache. It is now cached, so a new install.packages('dplyr') should result in pulling the cached binary and successful use of dpylr!

1 Like

I have just tried again and I could install it flawlessly.

Thanks again,

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.