Downloaded RStudio-1.1.423.dmg on macOS 10.13 and used hdiutil to mount it, but cannot open it

After downloading RStudio-1.1.423.dmg into my ~/Downloads directory on my macbook air (macOS 10.13), I tried opening it. I was hoping that would be all I'd need, but it did not open anything.

Then I used hdiutil as follows :
hdiutil attach RStudio-1.1.423.dmg

This created the folder /Volumes/RStudio-1.1.423, with the following content:
lrwxr-xr-x 1 sdas staff 13 Feb 2 01:53 Applications -> /Applications
drwxr-xr-x 3 sdas staff 102 Feb 2 01:52

Now I cannot figure out how to open the studio. I tried "open -a RStudio" command, but got the following error:
Unable to find application named 'RStudio'

I am not an expert on macOS or R. Just trying to learn. Not sure why I am unable to get RStudio to start. I'll appreciate any advice.

It's not clear it's your issue, but did you install R first? (R for mac)

After that, you should just download the latest version of the RStudio IDE and then open that .dmg.

Yes, before downloading RStudio,I had first downloaded R-3.4.3.pkg and installed it.
I can see it in my finder:
drwxrwxr-x 3 root admin 96 Feb 18 19:36
Also, I can see an R icon on my Launchpad and if I click on the icon, it opens up an "R Console".

I was able to resolve it. This is the sequence of actions that worked for me:

I opened the "Disk Utility" from the Launchpad. It showed RStudio-1.1.423 as one of the entries in the "Disk Images" list on the left side.

Next, I used right-click on that entry and among the list of commands in the menu, I chose the "Image from RStudio-1.1.423" command and chose the "Documents" directory as the destination folder.

It then created a new file "RStudio-1.1.423.dmg" file in the "Documents" directory:
-rw-r--r--@ 1 sdas staff 480018545 Feb 19 14:19 RStudio-1.1.423.dmg

I noted that the size of this .dmg was 480MB whereas the size of the "RStudio-1.1.423.dmg" file that I had downloaded into my "Downloads" folder was much smaller - 78.1 MB.

Next I double-clicked on the new "RStudio-1.1.423.dmg" file and then everything seemed to work as expected.


1 Like