Does updating the GCC compiler break installed packages?

I'm facing a situation at work where we are using R 3.6.1 with RStudio Server Pro running on CentOS 7 and have issues compiling some packages from source due to an older version of GCC (4.8.5).

The workaround suggested by @greg (i.e. installing pre-compiled binary packages from the public RStudio Package Manager) here works, but some packages still require compilation (e.g. {rstan}). I have been in touch with the admin team and requested an update of gcc, but their concern is this would break functionality for people with packages installed using the older version of the compiler. Is this a valid concern? I wish I could pick @sellorm's brain on this :slight_smile:.

1 Like

It shouldn't be a problem for packages that are already installed, since they're already compiled.

Best way to be sure would be to make a decent backup of the system and try it! At least then if it did cause issues you could revert back to the backup.

Unfortunately the version of gcc in CentOS 7 is very old (something like 5 versions behind the current release!). First and best option would be to upgrade to CentOS 8. If that's not possible I'd make the backup, install newer developer tools like these - - and then test like crazy!


Thanks @sellorm. Now off to convince my platform team.

@dragos: I run into the same problem at work too, and I can say it's safe to do so :slight_smile:

If admin still doesn't budge, then have them to at least install devtoolset, and add this line in .bashrc profile for you/shiny/rstudio-connect (or whatever username that will be running your deployment):

# using devtoolset-7 in my case
source scl_source enable devtoolset-7

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.