does not appear to contain CMakeLists.txt

I found several archived posts with this same error/question. However, I never saw a reply other than don't try to build it. I need to build a user version of RStudio on a large HPC cluster running Red Hat 6 to support a Grand Challenge project. I would very much appreciate knowing how. Thanks for any insight.

See the wiki articles for some extra instructions on how to build RStudio:

Thanks. I think I figured out my trouble. Or at least one trouble. Our system has a root set of libraries used to install system patches from the vendor. They are very old but consistent with model of supercomputer. As software maintainers, we have multiple versions of compilers in modules. These can be in the front of the path, ex: /N/soft/rhel6/gcc/5.3.0/bin:/usr/bin However, the package is jumping on the /ust/bin. How do I tell it to do look where I would like? Somehow multiple loading of the cmake module got it to look at the newer version, but that has not helped with the compiler. Below may help. Thanks for looking at this. Ray

[rsheppar@h1 rspm] which g++ /N/soft/rhel6/gcc/5.3.0/bin/g++ [rsheppar@h1 rspm] export CXX=/N/soft/rhel6/gcc/5.3.0/bin/g++
[rsheppar@h1 rspm] export CPP=/N/soft/rhel6/gcc/5.3.0/bin/g++ [rsheppar@h1 rspm] cmake .. -DRSTUDIO_TARGET=Desktop -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_DIR=/N/soft/rhel6/nonmem/rstudio/1.1.463/release -DCMAKE_INSTALL_PREFIX=/N/soft/rhel6/nonmem/rstudio/1.1.463/release
CMake Error at src/cpp/CMakeLists.txt:57 (message):
The compiler /usr/bin/c++ has no C++11 support. Please use a different C++

-- Configuring incomplete, errors occurred!
See also "/N/soft/rhel6/nonmem/rstudio/1.1.463/rstudio/rspm/CMakeFiles/CMakeOutput.log".
See also "/N/soft/rhel6/nonmem/rstudio/1.1.463/rstudio/rspm/CMakeFiles/CMakeError.log".

Sorry the formatting of the paste came out funny. I first did a "which g++" then I tried a few exports.
Ray again.

You might be able to use:

cmake \
-DCMAKE_C_COMPILER=/path/to/c/compiler \
-DCMAKE_CXX_COMPILER=/path/to/c++/compiler \

Great! Thanks! That moved things along:

-- Generating done
-- Build files have been written to: /N/soft/rhel6/nonmem/rstudio/1.1.463/rstudio/rspm

Now I can go back and try to follow the rest of the directions. Thanks again.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.