Dockerize shiny app always shows Hello World app not actual app from code

I have a code of 200 lines in R for shiny app which works perfect when I run from RStudio , while I have to Dockerize the app but when I run docker version of the app , I only see Hello-World app on localhost but not the actual code. I see inside container there are some extra files which docker always copies which is the problem, Can someone help me out ?

this is docker file

FROM rocker/shiny:3.5.1
RUN apt-get update && apt-get install libcurl4-openssl-dev libv8-3.14-dev -y &&\
  mkdir -p /var/lib/shiny-server/bookmarks/shiny
# Download and install library
RUN R -e "install.packages(c("library(shiny)","shinydashboard","xlsx", "V8"))"
# copy the app to the image
COPY app /srv/shiny-server/
# make all app files readable (solves issue when dev in Windows, but building in Ubuntu)
RUN chmod -R 755 /srv/shiny-server/
CMD ["/usr/bin/"]


This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.