"docker: unauthorized: authentication required." When extracting a image layer pulling rocker rstudio image

(Tag or category suggestions welcome)

I wanted to follow along a tutorial on using Docker with r and came across the rocker public images.

I'm using a old Mac so am unable to use the latest version of Docker and am instead using Docker Toolbox with a VM.

When I docker run hello-world I get the message "Hello from Docker! This message shows that your installation appears to be working correctly."

I then tried to follow the instructions over here on rocker Github page:

docker run -d -p 8787:8787 -e PASSWORD=blah --name rstudio rocker/rstudio

Each time I try, when the terminal window shows a layer as having downloaded and then gives me the "extracting" message, the pull fails and I get the error message "docker: unauthorized: authentication required."

Here's a screen shot of my terminal:

Just to check I tried pulling the r-base image to see if it works and it looks like it did:
(password=blah was accidentally added but doesn't seem to have harmed the download)

So this appears to be specific to rstudio.

How can I use the rstudio rocker image to run rstudio in my browser per the instructions and overcome this authentication error message?

Macs-MacBook:~ macuser$ docker info
Containers: 1
 Running: 0
 Paused: 0
 Stopped: 1
Images: 2
Server Version: 18.09.6
Storage Driver: overlay2
 Backing Filesystem: extfs
 Supports d_type: true
 Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
 Volume: local
 Network: bridge host macvlan null overlay
 Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: bb71b10fd8f58240ca47fbb579b9d1028eea7c84
runc version: 2b18fe1d885ee5083ef9f0838fee39b62d653e30
init version: fec3683
Security Options:
  Profile: default
Kernel Version: 4.14.116-boot2docker
Operating System: Boot2Docker 18.09.6 (TCL 8.2.1)
OSType: linux
Architecture: x86_64
CPUs: 1
Total Memory: 1.951GiB
Name: default
Docker Root Dir: /mnt/sda1/var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Experimental: false
Insecure Registries:
Live Restore Enabled: false

Pulling the image before running in two separate commands solved my problem

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.