Distill blog's Twitter card doesn't show image

I followed the instructions at https://rstudio.github.io/distill/metadata.html#twitter-card to make my Twitter card show an image, and I have preview=TRUE specified on a chunk later in the file. I just created this Distill blog, so the file structure is the same as the default.

base_url: https://prayaggordy.github.io/blog/
  site: "@prayaggordy"
  creator: "@prayaggordy"

But when I used Twitter's card validator (https://cards-dev.twitter.com/validator) on https://prayaggordy.github.io/blog/posts/2020-05-24-daily-charts/, the image was blank! The log even said INFO: twitter:card = summary_large_image tag found.

I tried every arrangement for the preview image listed at https://rstudio.github.io/distill/metadata.html#preview-images, but nothing worked. (Every time I uploaded to GitHub Pages I first knit the article and built the entire website.) I even tried to add the meta tags listed on Twitter's website, but that didn't work either.

(Sorry about the links—the forum limits the number of links new users can create.)

Thanks in advance!

Looks like there is a typo somewhere- the image is found but the link (https://https://prayaggordy.github.io/blog/posts/posts/2020-05-24-daily-charts/daily-charts_files/figure-html5/unnamed-chunk-2-1.png) is wrong:

1 Like

That was it! Pretty simple fix... whoops. I got confused with where the base_url needed to go: I put the above code in the article itself but never fixed the _site.yaml. Thanks!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.