Disabling smart punctuation doesn't work

I am using the latest version of RStudio and R Markdown as by 2021-03-27, on Windows 10. My Pandoc is of version 2.11.2.

I added the line smart: false to the front matter of my rmd file inside the indented section following html_document:, but the output does not change, as smart punctuation is still applied to what was ASCII punctuations in the original file. I tried using the 'output options' GUI, deselecting the option Use smart puntuation and then selecting it again, but it did nothing but changing those false to no.

With smart: no in the front matter, the first few lines of the knit message read:

"C:/Program Files/RStudio/bin/pandoc/pandoc" +RTS -K512m -RTS ttt.utf8.md --to html4 --from markdown+autolink_bare_uris+tex_math_single_backslash --output ttt.html 

-smart is not found in the message. It is supposed to be following markdown as an extension, which worked well and disabled smart punctuation when I tried using pandoc with command lines:

pandoc smart.md -f markdown-smart -t html -o smart.html

Could it be a bug, or is there something wrong with my configuration? I'd appreciate any help.

Yes there was an issue with the smart argument. Since rmarkdown 2.2 it has been removed as an argument from html_document and other formats.

Pandoc activate it by default and if you need to deactivate it, you need to use now:

    md_extensions:  -smart


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.