devtools::load_all() shortcut not working with renv

Hi all,

I've just updated RStudio (Build 576 on Intel MacOS 12) and I've found that using a shortcut (Cmd+Shift+L) to execute devtools::load_all() no longer works in a project that uses renv for package management.

I have verified that the shortcut is registered in RStudio and that there are no clashing shortcuts. I have also checked that the shortcut works in other projects that aren't using renv.

Has anyone else come across this issue, or how I might begin to debug this?


Can you confirm whether devtools is installed within that project?

Yes, devtools was installed, and calling devtools::load_all from the console worked fine.

However, when I opened RStudio the next day, the shortcut worked. So it seems like it was just a temporary issue. Perhaps some cache was refreshed by the restart?


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.